Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to build the latest version of subversion on ubuntu 12.10 and was having some trouble completing ./configure as I seemed to be getting a never ending stream of configure: error: x not found messages. I installed apr and supplied the paths to the apr-1-config file to get rid of the first, then I installed sqlite etc. and currently I am working on configure: error: Expat not found.

Prior to attempting an install of 1.7.7, I had just used apt-get install subversion which installed 1.7.5 and was working fine. My question is, why does 1.7.5 work on my machine if I didn't have sqlite, apr and all the other dependencies that seem to be needed now that I'm it from the source? does 1.7.5 not have such dependencies or were they installed during my apt-get command and I just needed to link to them?

share|improve this question

1 Answer 1

up vote 6 down vote accepted

Some distributions (including Ubuntu) separate packages that contain libraries into two packages: one containing the files needed to run programs that use the library, and a -dev package containing the files needed to compile programs that use the library. So what you're really missing are the various -dev packages to go with the libraries that Subversion needs. When you apt-get install subversion, it installs the libraries, but not the header files and other compile-time-only bits.

For example, installing subversion on Ubuntu 12.10 will install libsqlite3-0, but not libsqlite3-dev.

Running apt-get build-dep subversion should install the necessary -dev packages for you.

share|improve this answer
    
I have successfully installed 1.7.7 using the -dev package from apt-get which would be for 1.7.5, I'm assuming. Might there be issues using different -dev and source packages together? –  stariz77 Dec 2 '12 at 4:11
1  
@stariz77, apt-get build-dep will install the -dev packages for the libraries needed by the package you give it. If a newer version has added new dependencies, they won't be installed, and you'll have to figure out which packages to install manually. But for a minor release (like from 1.7.5 to 1.7.7) that's not usually an issue. –  cjm Dec 2 '12 at 4:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.