Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

The installation of debian wheezy defaulted to the KDE desktop environment. How do I remove it and switch to GNOME 2 (the version that is used in stable)?

I fear that if I just install gnome-core, it will install GNOME 3. Can I just make sources.list point to an older version of some package?

I prefer GNOME 2 because it works well with bluetile (I don't want MATE, or other copies).

share|improve this question
1  
Why don't you want MATE? It just picks up from where GNOME 2 left off. –  Renan Dec 2 '12 at 2:05
    
I didn't think it would be able to work with bluetile. I'll try it out. –  anonymous Dec 2 '12 at 2:39
add comment

1 Answer

up vote 2 down vote accepted

I installed MATE and it looks just like GNOME 2. Bluetile runs fine as well, but it didn't start running upon logging in. Here's a solution I found online:

Adding these two files is one possible solution:

/usr/share/xsessions/mate-bluetile-session.desktop

[Desktop Entry]
Encoding=UTF-8
Name=MATE + Bluetile
Comment=Tiling window manager
Exec=mate-bluetile-session
Icon=bluetile.png
Type=XSession

/usr/bin/mate-bluetile-session

#!/bin/bash

mateconftool-2 --type bool --set /apps/caja/preferences/show_desktop False
mateconftool-2 --type string \
    --set /desktop/mate/session/required_components/windowmanager bluetile
exec /usr/bin/mate-session

I'm not sure why the person I'm quoting decided to disable the desktop, mine is set to True. Make sure that /usr/bin/mate-bluetile-session is executable. You should then be able to select "MATE + Bluetile" from the options list when you login.

A second problem I've found is that the run application dialog doesn't come up with win-p. I installed gexec, mapped that to win+p, and changed the bluetile shortcut to Mod1+p.

Another solution: install grun and map that to win+p. Grun seems like the more traditional run application dialog box.

relevant:

  1. run application dialog in gnome2 (alt-f2) without gnome-panel

  2. http://darkness.codefu.org/wordpress/2004/07/popping-up-the-gnome-run-application-dialog-from-a-script/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.