Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My web server is showing an Apache 2 test page when it should be showing the Drupal install page. I've set up permissions correctly, so the last thing I've read it could be are the iptables firewall rules for port 80. I can't access php.ini or .htaccess on this machine, so I need a fix that doesn't involve those.

share|improve this question

closed as off-topic by Jeff Schaller, Stephen Harris, slm Jul 15 at 12:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
If you're seeing the a page, the firewall's open (at least from where you're currently browsing). Something's wrong in your configuration (possibly just the url you're using) and there's no way to tell what with the details you've given. – Mat Nov 29 '12 at 12:46
    
I am doing a drupal install so it should be opening on install.php or index.php because all the folders and files are there with settings.php changed permissions before install can take place. But because this is my first ever command line install I am obviously missing something for CentOs. – freja Nov 29 '12 at 12:58
    
thanks that's good to know about firewall. I think it has to do then with php.ini or .htaccess both of which will not let me open as root which is pretty insane. – freja Nov 29 '12 at 13:00

Post your httpd.conf file, and the pwd of the directory in which Drupal resides. I suspect that Apache is configured for a different directory. Note that some servers are set up so that the user can cd into public_html right from /home/user/ but the true path to the webroot it often /var/www/site/public_html/ not /home/user/public_html/ as implied in the shell.

If you are on Ubuntu, then this may help.

share|improve this answer
    
I find the directories confusing still, I will admit. I extracted drupal into /var/www but I know when using cpanel for instance, drupal must go in public_html. – freja Nov 29 '12 at 13:03
    
and I cannot find httpd.conf when I # find – freja Nov 29 '12 at 13:04
    
got it now sorry- will have to read a lot about this file settings for apache. – freja Nov 29 '12 at 13:10
    
Extract Drupal into /var/www/yourSiteName/public_html/ and configure an Apache virtual host for that directory. – dotancohen Nov 29 '12 at 13:20
    
I am looking at httpd.conf right now and it looks like I should edit this DocumentRoot "/var/www/html" #ServerName ayz-abc.mysite.com/ # Other directives here RewriteEngine On RewriteCond %{HTTP_HOST} !^ayz-abc.mysite.com$ RewriteRule /.* ayz-abc.mysite.com [R] – freja Nov 29 '12 at 13:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.