Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have recently bought a Dell XPS Touch. I'm dual booting Windows 7 with Fedora 16 (Verne). Right out of the box, Fedora reports 1 hour 26 minutes of battery life at full charge, while Windows reports a whopping 4 hours!!

Why is this happening? Am I missing some acpi module or something?

A friend suggested to me that this could be due to the fact that I'm using nouveau instead of the proprietary nvidia driver. Does that sound reasonable?

Update

I am now on Debian Wheezy and still the issue persists. Removed Fedora tag.

share|improve this question
3  
Check if anything untowards is going on with powertop. –  Gilles Nov 28 '12 at 23:54
    
Installed powertop and ran it. Things seem normal enough... –  Joseph R. Nov 29 '12 at 0:24
    
Battery all works bad in Linux, so not a dell specific problem. –  warl0ck Dec 29 '12 at 12:38
    
That's a real bummer. But I had a different laptop with a similar setup and I don't recall such a large performance penalty. Is it a driver-specific thing? I was going to report that I tried battery life on a minimalist LFS (Linux from Scratch) build and I bumped again into this 2-hour mess. Is it kernel-inherent perhaps? –  Joseph R. Dec 29 '12 at 13:18
    
Nouveau has nothing like power management. @warl0ck, true, chromebooks/notebooks usually run out of power within 10 minutes... Jocking aside, Linux is not always as efficient as Windows when considering power management. Just keep in mind that Fedora and Windows are lying and try it yourself using the same protocol... Same screen brightness, same HDD spin-down timeout, "same" drivers (nvidia) and so on. –  Gael Feb 20 '13 at 16:34
add comment

2 Answers

up vote 2 down vote accepted

Dell XPS seems to have an Nvidia hybrid (Optimus) graphics card. With correct driver setup, only the low-powered intel card is used, if you run more demanding applications, there's an automatic switch to the other card.

By default, this is not supported (to my knowledge) in linux systems, and this is why the power consumption is so high: it uses the full power all the time. There's a project called bumblebee, that adds support for such hybrids, so you can switch them on and off manually.

Bumblebee Project

On my dell (not an XPS), this worked wonderfully and got me up to the expected five hours battery time.

share|improve this answer
    
+1 This helped but only somehwat. It upped my battery life by 50%. I'm accepting it since it seems to be the best way at the moment. –  Joseph R. Dec 18 '13 at 14:13
1  
A recent discovery: I installed Fedora 20 on my Laptop (KDE, Bumblebee, nvidia drivers) and all I got out of it was a 3.5h battery time. It drained my machine at 18 W. I then installed the current Ubuntu GNOME edition (also using Bumblebee, nvidia drivers) and got 5.5 h from it, it using only 9 W. Somewhere between Fedora and KDE, something just eats up energy. –  Simon Hellinger Dec 20 '13 at 8:42
    
Interesting. Thanks for sharing. –  Joseph R. Dec 20 '13 at 11:36
add comment

Are the reported values realistic? If so, check how much your CPU is throttled e.g. in /proc/cpuinfo - if it doesn't run on lower frequencies without heavy load, it's just burning power for no reason (well, you could warm your breakfast on it). Adjusting display backlight might also help.

share|improve this answer
    
They are realistic in the sense that Fedora would suspend after the time it has reported and the BIOS reports a low battery when I try to power it back on. I tried grep MHz /proc/cpuinfo and all the cores seem to be running at 800 MHz at no load, which I'm guessing is quite alright. Adjusting backlight isn't really an option. Why should I limit my performance rather than fix the issue? –  Joseph R. Nov 28 '12 at 23:14
    
@JosephR. for it may be part of the issue. I would expect Windows to dim the backlight after some period of not being used (before suspending) or depending on ambient light, if you have recent enough hardware (which you do). –  peterph Nov 29 '12 at 11:49
    
A friend suggested to me that this could be due to the fact that I'm using nouveau instead of the proprietary nvidia driver. Does that sound reasonable? –  Joseph R. Nov 29 '12 at 12:23
    
Good point, since the GPU in tablets are usually rather powerful. Do you have any desktop effects enabled? –  peterph Nov 29 '12 at 13:52
3  
Can you switch to some other desktop - at least for testing? Something lighter like LXDE or XFCE? –  peterph Nov 29 '12 at 13:57
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.