Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I wanted to install a dlna server on my asus eeepc, and tried minidlna. My eeepc runs Wheezy, so I just had to run apt-get install to install minidlna on it. The first time I ran it, everything worked fine, but once I restarted the service, I could never access it from VLC (running in Squeeze) again.

My config file:

media_dir=V,/home/media/vid
media_dir=P,/home/media/pic
media_dir=A,/home/media/aud

db_dir=/home/user/.minidlna
log_dir=/var/log

network_interface=wlan0
port=8200

inotify=no

Thanks in advance for helping!

share|improve this question
    
Use netstat -ntpl from root account to check if minidlna is listening on port 8200. You can also check and post minidlna log file /var/log/minidlna.log –  pbm Nov 28 '12 at 21:38
    
MiniDLNA wasn't listening on port 8200, and the minidlna log is empty. But, I noticed that the directory for the databases minidlna uses was set to the wrong user. chown -R user:user fixed it! Thanks! –  evuez Nov 29 '12 at 17:12
    
add this as answer and accept it... –  pbm Nov 29 '12 at 18:49
add comment

1 Answer 1

up vote 0 down vote accepted

Fixed it by changing the rights on the db directory and setting the right user:

chown -R user:user db_dir_path
chmod -R 755 db_dir_path
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.