Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just installed the latest version of opensuse on virtualbox just to learn some stuff and I'm having some strange problems with my mouse. Sometimes while I'm just moving my mouse around not clicking anything all my open windows do this sort of alt tab behavior where it shows all of the windows for a brief second aligned in a sort of tiled fashion. For instance, if I have 4 different apps open they will all resize to fit one in each corner top right, top left, bottom left, bottom right. Then almost as quickly as they came they disappear and sometimes my windows switch to a different app that I wasn't working in at that time. I'll try and grab a screenshot the next time it happens.

On top of this, my scroll wheel doesn't work in most applications (it does in terminal and chrome but not firefox and other places I thought it'd work). Now this may be just how linux is, but it seems weird that it is.

screenshot

share|improve this question
1  
What desktop environment or window manager is running on Linux (e.g. KDE, Gnome, XFCE, …)? Have you installed the VirtualBox extensions in the VM? Is the mouse in a particular location when you see these unwanted effects? I suspect this is a normal feature but VB is causing it to trigger at the wrong time. –  Gilles Nov 27 '12 at 23:38
    
KDE, yes to the desktop extensions but i remember I got some errors back when it was first installing it but it seemed to complete successfully so the problem may be coming from there. The resolution was stuck on 640x480 until that installed successfully so I just figured it worked. It seems to be happening when the mouse is about 1/4 from any side of the screen (2 inches or so from the bottom, 3 from the left right, etc.) I took the screenshot from windows because print screen wasn't doing anything while the screen was messed up like that on linux. That's why u see the win stuff there. –  Codezilla Nov 28 '12 at 0:59
add comment

2 Answers 2

up vote 1 down vote accepted

From the screen shot it looks like the KDE, "Present Windows" from "Screen Edges". I'm not sure how they act in a VM but when the mouse gets to the edge or corner position it triggers what looks like "Present Windows".

To see if this is the case open "Configure Desktop" -> Workspace Behavior -> Screen edges. It should display a picture of a monitor and have 9 selectable square on it. You can turn each one off or select a different action for that part of the screen.

Because you are in a VM this feature may be more annoying than helpful :)

share|improve this answer
    
I'll give it a try and let you know in the next few days, I don't have time to work on it today. –  Codezilla Dec 1 '12 at 7:38
add comment

I was wrong, first answer worked for me.

I had a similar problem and it seems to have been fixed by:

Right clicking the desktop->Desktop Settings->Mouse Actions.

Then removing the 'Vertical-Scroll' action which was set to 'Switch Desktop'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.