Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I run docky which is programmed with mono so I think the binfmt is running correctly, but proc-sys-fs-binfmt_misc.automount complains about it, since I don't have /proc/sys/fs/binfmt_misc/CLR

I already have CONFIG_BINFMT_MISC=y in my kernel config.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

/proc/sys/fs/binfmt_misc/CLR gets created by the kernel when you register a binary format that you've named "CLR". Are you able to register one manually?

echo ':CLR:M::MZ::/usr/bin/mono:' | sudo tee /proc/sys/fs/binfmt_misc/register

If this works, then the solution is probably that you should add a file in /etc/binfmt.d; see man binfmt.d for more information.

Are you sure systemd is complaining about it not already being there? systemd's systemd-binfmt.service is supposed to do that for you (but I think it does need that config file in order to do it).

share|improve this answer
    
Thanks for the heads up, I thought CLR was a standard interface that means something ... And the problem is that I disabled auto-mount in kernel, now it's resolved –  warl0ck Nov 27 '12 at 4:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.