Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to set up a dualboot Win8/Linux on my HP tablet (touchsmart tm2-1050ez). However, when I'm finished setting it all up, after a few more reboots, I'm not able to boot to Linux anymore, as I keep getting the error

BUG: soft lockup - CPU#0 stuck for 23s! [swapper/0:1]

over and over again right after GRUB. I've left it sit for an hour, only to retrieve a screenful of these messages (only varying slightly in the time it's been stuck). Even recovery mode won't work.

So far I've tried Fedora 17, Ubuntu 12.10 and most recently Mint MATE 14, all of which have died in this exact fashion within a day of the original setup.

I've googled the problem, but all I could come up with was to run a BIOS update, which I already did and didn't help anything.

Help would be much appreciated.

share|improve this question
1  
Have you tried completing the installation without installing any updates? The attempt here is to determine whether the problem is with the base system or an update. –  KayakJim Nov 26 '12 at 15:02
    
Just tried that out, seems not to occur with out-of-the-box Mint 14. I'll try installing some of the packages I installed last before the issue occurred, one-by-one, hoping to find the culprit. –  Axim Nov 26 '12 at 17:28
2  
Probably a kernel bug, or bad ACPI tables. Unfortunately not the kind of things you can repair without solid expertise, you may be reduced to waiting for a kernel or firmware upgrade. –  Gilles Nov 26 '12 at 23:43
1  
(1) When that happen, on the next reboot to linux, try edit the grub line and add "acpi=off", see if that helps at all. (2) Can you boot into windows right after that CPU error? –  John Siu Dec 14 '12 at 22:09
1  
That is the kind of thing that I have seen caused by a bad stick of RAM, but in your case that is not likely. Sounds like you shouldn't be doing this unless you can find someone else with the same device as you that is doing the same thing. Otherwise, its just guessing. –  djangofan Jan 2 '13 at 17:34
show 5 more comments

2 Answers

Edit Grub-Boot-Line and append to kernel-line:

    coldplug DRV_DEBUG=verbose

to get information about when getting stuck (which module(s) loaded just before stuck).

 - sorry for posting as answer. not enough reputation yet. - 
share|improve this answer
add comment

Please add acpi=off noapic to your boot parameters. It will disable any ACPI functions (that is the system that controls your dynamic speed fans, the power button behavior, sleep states, etc.). This verifies if your problem is related to energy functions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.