Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On debian squeeze, I setup a bridge based on eth0. My /etc/network/interfaces is

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#allow-hotplug eth1
#auto eth0
iface eth0 inet manual
iface eth0 inet6 manual

auto br0
iface br0 inet dhcp
    bridge_ports    eth0
    bridge_stp      off
#    bridge_maxwait  0
    bridge_fd       9
bridge_hello 2
bridge_maxage 12

Despite setting eth0 to manual, it get's an ip address via DHCP. Setting ifconfig eth0 down explicitly, disables the interface for a few seconds before it comes back up again.

How can I disable eth0 and use br0 has my only network interface?

share|improve this question
    
I'm not sure about this (that's why it's a comment), but have you tried restarting the network manager so it will accept eth0 as manual? – David Kohen Nov 26 '12 at 13:54
    
You try to comment all lines for eth0 (except the bridge_ports one of course) and restart networking. – Not Now Nov 26 '12 at 19:12
3  
Are you running NetworkManager or Wicd? Without them the interface shouldn't come up automatically. Check the system logs (/var/log/*, look for files modified around the time the network came up) for clues. – Gilles Nov 26 '12 at 23:40
    
Wicd was running. Can you write it as an answer, so I can close this question? – Shoan Nov 27 '12 at 11:28

Gilles appears to have answered this one in the comments, with:

Are you running NetworkManager or Wicd?

as followed up by the OP:

Wicd was running.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.