Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed Debian with the Gnome Live CD on my notebook. Because there are still some applications which I need, it was necessary that I also have a Windows 7 system installed.

Based on some tutorials I installed Windows 7 first and then Debian.

After the Debian Installer from the live cd was finished, I tried to reboot my notebook. Directly after the BIOS screen I see the output that no BootDevice was found.

The output of fdisk -l is:

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13        4961    39743488    7  HPFS/NTFS
/dev/sda3            4961       15567    85186561    5  Extended
/dev/sda5   *        4961       15131    81689600   83  Linux
/dev/sda6           15131       15567     3495936   82  Linux swap / Solaris

According to the partition table, my Linux partition should be bootable, but I cannot start Windows 7 or Debian.

share|improve this question
1  
could it be because your bootable linux partition is on extended partition? You should create boot partition as sda3 (100-200MB) while installing debian and extended as sda4 with sda5 holding your / etc.. –  UldisK Nov 25 '12 at 13:44
    
Thanks! That was the problem! Now it works just fine :) –  mhp Nov 25 '12 at 14:29
    
@user1271422 Linux doesn't care about primary vs extended partitions. mhp: Whatever was wrong with your first installation, the partition type was not the problem. Maybe you skipped an installation step the first time. By the way, the “bootable” flag on the Linux partition is also irrelevant; Windows used to need it, but I don't know if that's still the case with Windows 7. –  Gilles Nov 25 '12 at 20:43
    
Anyway, putting the Linux partition on an extended one, solved the problem :) –  mhp Nov 26 '12 at 8:17

2 Answers 2

up vote 2 down vote accepted

you've installed Debian in a logical partition and in the msdos partition table you can not set logical partition as bootable

you can resize the first partition (/dev/sda1) and make a 1G ext3 or ext4 partition before that then run a live boot and: mount the new partition (that is /dev/sda1 now) under somewhere like /mnt

# mount /dev/sda1 /mnt

then install grub2 bootloader by:

grub-install --no-floppy --force --root-directory=/mnt
share|improve this answer

Here the Detailed Visual-Guide to Boot from Debian Installation Media on Win8: http://install-climber.blogspot.it/2013/01/howtoinstall-linuxdebian7wheezy-pcwindows8preinstalleduefi.html

share|improve this answer
1  
Please explain your answer in more detail. See How to Answer? –  mtk Jan 12 '13 at 12:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.