Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I try to edit or assign the IP using this command:

system-config-network-tui &

Terminal opens a console which is uncontrollable, just like this:

Redhat

This happens on CentOS and Red Hat.

share|improve this question
    
@harish.venkat Great job It worked. Dear put this as an answer so I can accept it.Thanks and Good day –  OmiPenguin Nov 25 '12 at 8:09
add comment

2 Answers 2

up vote 3 down vote accepted

try not opening it as background process system-config-network-tui instead of system-config-network-tui & this has worked for me and later i switched to editing config files at /etc/sysconfig/network-scripts/

share|improve this answer
add comment

Of course it doesn't work ... It's a ncurses based program that uses a loop to refresh current screen, you run it in background, you end up with a mess ..

If you just need to setup some IPs, why won't you just do it with ifconfig or nmcli (for network manager) ?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.