Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Whilst trying to make this request I have this error.

I have tried to run "sudo pecl install pecl_http" but always fails.

Could not find curl/curl.h

After I have tired(yum instead of apt-get because I am running centOS):

sudo yum install libcurl4-gnults-dev

But this sends:

No package libcurl4-gnutls-dev avaliable Error: Nothing to do.

Any more ideas guys I'm a bit stuck.

share|improve this question

migrated from stackoverflow.com Nov 23 '12 at 21:06

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Did some googling looks like

curl-devel is the name of package not libcurl4-gnults-dev

so

sudo yum install curl-devel

Should do.

share|improve this answer
    
Thanks. Yeah I googled for some answers. For anyone else who runs into this issue I used "sudo yum install curl-devel" and worked perfectly thanks. Now I will restart and retry. Cheers :) –  Lewis Boyles-White Nov 23 '12 at 17:53

Try this:

First, install pear:

yum install php-pear

You may need to install these packages for dependencies:

yum install zlibc
yum install libcurl4-openssl-dev

add "extension=http.so" to php.ini and restart Apache:

service httpd restart

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.