Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using winFF in Ubuntu 10.04. WinFF is a graphical frontend to ffmpeg.

Typically, after selecting a file in WinFF, setting my conversion settings and pressing the "Convert" button, a console appears with output from the conversion process and prompts requesting permission to continue.

However, now, when I press convert, I only see a blank console with a command prompt such as:


I thought I had misconfigured something, but I reinstalled everything but problem continues. Could you help me ?

In general console output still works, since I see output when I run the following script:

echo -n "\033]0; Converting _quot;LIKE A G6_quot; (OFFICIAL) FAR EAST MOVEMENT (FM) feat (1/1)\007"
/usr/bin/ffmpeg -i "/home/oneat/dwhelper/_quot;LIKE A G6_quot; (OFFICIAL) FAR EAST MOVEMENT (FM) feat.flv" -acodec libmp3lame -vcodec msmpeg4 -ab 192kb -b 1000kb -s 640x480 -ar 44100 "/home/oneat/_quot;LIKE A G6_quot; (OFFICIAL) FAR EAST MOVEMENT (FM) feat.avi"
read -p "Press Enter to Continue" dumbyvar
rm "/home/oneat/.winff/ff110111193250.sh"
share|improve this question
Maybe, but not with the little information you've posted. You need to describe precisely what you're doing: where did you get the program (FFGUI?), on what OS (Ubuntu, but what version), how do you start it (click on a menu entry? command in a terminal?), what happens exactly? Be precise enough so that someone can reproduce what you're doing on their machine. – Gilles Jan 10 '11 at 20:00
paste the whole shell command you use for it please. – Danny Staple Jan 11 '11 at 9:58
Is _quot;LIKE A G6_quot; actually part of the file name or was this some copy and pasting error? Also, are you saying that this series of commands work when you type them in but not when you run your script using something like $ ./myscript.sh? – Steven D Jan 11 '11 at 22:26
FFMPEG just doesn't print anything! It's good with code! There is just problem that gui doesn't print commands to SHELL!! – oneat Jan 12 '11 at 16:39
@oneat, I heavily edited your question. Please make sure it accurately reflects your problem. – Steven D Jan 13 '11 at 18:15

I don't know anything about this software, but after quickly installing it, I get the impression it was not well packaged.

You said that you tried reinstalling the package; however, when you reinstalled it, did you also remove its configuration files? By default in Debian, Ubuntu, and other distributions, configuration files are left behind in case you reinstall again. I would try something like the following(as root):

# apt-get purge winff
# apt-get update
# apt-get install winff

From the apt-get manual page:


purge is identical to remove except that packages are removed and purged (any configuration files are deleted too).

share|improve this answer
I did it. It didn't work. I even reinstalled ffdshow and now inserting these commands directly to cmd works. But Winff still can't pass them there.Any possibilities why? – oneat Jan 23 '11 at 19:30

I had the same problem.

Solution (not nice though):

  1. Go on Options and Select Display CMD Line
  2. Click on Convert:

    • A terminal appears with commands
    • Copy the contents of the window, save it in a file
    • Run at as a shell script (sh filename)
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.