Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I wanted to run a tutorial program for OpenGL in my Slackware 14.0. It compiled well, but when I try to run it, it quits with an error:

error: GLSL 3.30 is not supported. Supported versions are: 1.00 ES, 1.10, and 1.20

I am using radeon driver. How to upgrade OpenGL?

share|improve this question
    
I rather think the version might too high. Where is the tutorial from? –  klapaucius Nov 23 '12 at 8:05
    
Here: opengl-tutorial.org. But I got the answer and it seems to be hard to make it work: linuxquestions.org/questions/linux-software-2/… –  user4035 Nov 23 '12 at 11:10

1 Answer 1

In the latest Mesa release, Mesa 9.0, the Radeon driver supports only GLSL 1.20. Upgrading the driver won't fix your problem.

You need to replace the opensource Radeon driver with the proprietary one, which should support the highest GLSL version that the hardware is capable of.

share|improve this answer
    
Oh. My video card is too old: Radeon 9600 and is not supported by the proprietary drivers any more. I'll have to wait until the open source will support the new functions. –  user4035 Jan 22 '13 at 6:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.