Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

In my crunchbang installation with X11, openbox, my wireless usb mouse is listed at both /dev/psaux and /dev/input/mouse0. It's working fine apart from the scroll wheel, which although active, is far too sensitive.

I'm thinking maybe the kernel is raising double the scroll events that it should be? Not sure what to check out even if this is the case?

I tried adjusting sensitivity via lxinput but it affected everything on the mouse apart from the actual scrollwheel.

xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v2.0    id=9    [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v2.0    id=10   [slave  pointer  (2)]


xinput test 9 results in expected mouse motion events (but nothing for button clicks/scrollwheel) xinput test 10 results in 'unknown class' with no events fired.

share|improve this question
You can see what events X11 is getting by using xinput. In a terminal, do an xinput list to find the device id, then xinput test «device-id» to see all the events. (Control-C it to stop) –  derobert Nov 21 '12 at 17:19
that bug refers to acceleration, the constant speed with mine is too fast. See updated xinput –  rutherford Nov 21 '12 at 17:58
@rutherford have you tried debugging it with xev ? –  Dārayavahuš tdi Feb 17 at 17:18

2 Answers 2

If it's a Microsoft mouse, try resetmsmice, which will fix this problem, without having to unplug and replug the mouse receiver. Many thanks to the author Paul F Richards, also the Ubuntu launchpad bug report

share|improve this answer

Try to increase Scrolling Distance to 3, 3, 3

xinput --set-prop 10 274 3, 3, 3
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.