Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On a fresh install of Debian Wheezy, I have Leafpad 0.8.18.1-3. Following instructions I created a .gtkrc-2.0 in my home folder and put the commands to change the text area colors. This had no effect.

The problem has been noted before, but didn't get an answer. I did find mention of someone having it work several years ago.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

If you use a Desktop Environment, your .gtkrc-2.0 may be totally ignored. In Xfce4 for example, you can add rules manually through xfce4-settings-editor, under xsettings -> Gtk.

You can also try editing the gtkrc file for the Gtk+ theme you are currently using. It is under /usr/share/themes/THEMENAME/gtk-2.0/gtkrc or ~/.themes/THEMENAME/gtk-2.0/gtkrc

share|improve this answer
1  
Only IceWM, no DE and no prior .gtkrc-2.0. I put the config info in /usr/share/themes/Default/gtk-2.0-key/gtkrc and then it worked. I deleted .gtkrc-2.0 from home but found it was still needed. Then removed from /usr/.../gtkrc and it still worked. Now Leafpad reads config changes directly from the .gtkrc-2.0 in home directory. –  user5184 Nov 20 '12 at 5:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.