Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I move my mouse slowly over the desktop the pointer jumps often a few pixels (one or two) in the opposite direction of which I move my mouse. Horribly when trying to set the cursor around some semicolons in eclipse. I guess this is the result of a wrong set resolution. I suppose this is because the mouse was set initially really fast and even if I do xset m 1/2 3, the mouse is just to fast and unprecise for me.

It aready tried to configure the xorg.conf like this:

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
    Option      "Device"    "/dev/mouse"
    Option      "Protocol"  "Auto"
    Option      "Name" "Logitech G3"
    Option      "Resolution" "2000"
EndSection

But with no effect.

EDIT But one new thing I recognized is that, in the mouse settings, I can slide the slider to max or to min. Mouse behaviour (sensitivity) does not change. I found somthing curoious too in /var/log/Xorg.0.log:

[   257.409] (II) config/udev: Adding input device Logitech USB Gaming Mouse (/dev/input/event1)
[   257.409] (**) Logitech USB Gaming Mouse: Applying InputClass "evdev pointer catchall"
[   257.409] (II) Using input driver 'evdev' for 'Logitech USB Gaming Mouse'
[   257.409] (**) Logitech USB Gaming Mouse: always reports core events
[   257.409] (**) evdev: Logitech USB Gaming Mouse: Device: "/dev/input/event1"
[   257.409] (--) evdev: Logitech USB Gaming Mouse: Vendor 0x46d Product 0xc042
[   257.409] (--) evdev: Logitech USB Gaming Mouse: Found 20 mouse buttons
[   257.409] (--) evdev: Logitech USB Gaming Mouse: Found scroll wheel(s)
[   257.409] (--) evdev: Logitech USB Gaming Mouse: Found relative axes
[   257.409] (--) evdev: Logitech USB Gaming Mouse: Found x and y relative axes
[   257.409] (II) evdev: Logitech USB Gaming Mouse: Configuring as mouse
[   257.409] (II) evdev: Logitech USB Gaming Mouse: Adding scrollwheel support
[   257.409] (**) evdev: Logitech USB Gaming Mouse: YAxisMapping: buttons 4 and 5
[   257.409] (**) evdev: Logitech USB Gaming Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   257.409] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.1/usb3/3-1/3-1:1.0/input/input1/event1"
[   257.409] (II) XINPUT: Adding extended input device "Logitech USB Gaming Mouse" (type: MOUSE, id 8)
[   257.409] (II) evdev: Logitech USB Gaming Mouse: initialized for relative axes.
[   257.409] (**) Logitech USB Gaming Mouse: (accel) keeping acceleration scheme 1
[   257.409] (**) Logitech USB Gaming Mouse: (accel) acceleration profile 0
[   257.409] (**) Logitech USB Gaming Mouse: (accel) acceleration factor: 2.000
[   257.409] (**) Logitech USB Gaming Mouse: (accel) acceleration threshold: 4
[   257.409] (II) config/udev: Adding input device Logitech USB Gaming Mouse (/dev/input/mouse0)
[   257.409] (II) No input driver specified, ignoring this device.
[   257.409] (II) This device may have been added with another device file.

Still my question is:

How do I setup my mouse correctly in Debian wheezy?

share|improve this question
    
Have you tested the mouse on another computer or OS to make sure the mouse is not defective? If you remove the mouse entry entirely from Xorg.conf, does it work? –  jordanm Nov 18 '12 at 17:17
    
Mouse is under /dev/input/mice, /dev/input/mouse0. Just like @jordanm said, Debian generally doesn't need a Xorg.conf at all, unless you nee some entries for some proprietary GPU. And which kernel are you running? –  Teresa e Junior Nov 18 '12 at 18:54
    
I just tested it. The mouse works well on my laptop(Win7x64). I discovered the malfunction as the xorg.conf had no entry for the mouse. The entry in my question I added manually. Kernel is 3.2.0-4-amd64. The mouse is a "Logitech G3". –  ManuelSchneid3r Nov 18 '12 at 19:09
    
Have you checked with those entries under /dev/input/? –  Teresa e Junior Nov 18 '12 at 19:14
    
I can't tell if this solves your problem, but you may try a kernel optimized for desktops instead, like Liquorix from liquorix.net. It may be also some bug in xserver-xorg-input-mouse. –  Teresa e Junior Nov 18 '12 at 19:36
show 2 more comments

1 Answer

up vote 1 down vote accepted

Okay well that took a while. But I got a solution. Meanhile I even bought a new mouse.

When you have a mouse with a high dpi you can use its standard dpi with minimum acceleration (which is anyway going to be to fast) follow these steps:

  1. Get xinput

    $ sudo apt-get install xinput

  2. List your input devices

    xinput --list

    You should get an output like this:

    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer            id=4    [slave  pointer  (2)]
    ⎜   ↳ HID 1d57:0005                         id=8    [slave  pointer  (2)]
    ⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard           id=5    [slave  keyboard (3)]
        ↳ Power Button                          id=6    [slave  keyboard (3)]
        ↳ Power Button                          id=7    [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard          id=10   [slave  keyboard (3)]
    
  3. I my case my "HAMA uRAGE" is HID 1d57:0005. Remember its id.

  4. Now comes the magic. I would prefer to be able to increase the resolution but debian obv dont want me to. Type in:

    xinput set-float-prop <id> 'Device Accel Constant Deceleration' <d>;
    

where is to be replaced by your mouse's id and the deceleration factor. Your have to play around a little bit. Like me. At least X doeas not need a restart for applynig the changes. Greets

EDIT:

To make it permanent edit X11 settings.

sudo nano /etc/X11/xorg.conf

Add: Option "ConstantDeceleration" "10"

Example:

Section "InputClass"
   Identifier "My mouse"
   MatchIsPointer "true"
   Option "ConstantDeceleration" "10"
EndSection 

But if you often change your system an want to have some kind of portable config, add xinput to your .xinitrc.

Mine is

xinput --set-prop "HID 1d57:0005" "Device Accel Constant Deceleration" 2
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.