Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to create a .iso file using mkisofs.

I have the following folders:

my OS

I used the following command:

mkisofs -R -input-charset utf8 -b bin/boot.bin -no-emul-boot -boot-load-size 4 -o os.iso bin

the command was run from the parent directory (my OS) and I got the following error:

genisoimage: Uh oh, I cant find the boot image 'bin/boot.bin' !

I checked, and the file bin/boot.bin does exists. I tried writing ./ before the directory, and using real paths, but no good.

Can any one help me?

share|improve this question
Could you give us the file permissions of bin/boot.bin? – Philippe Blayo Nov 18 '12 at 11:11
@PhilippeBlayo the permissions are: -rw-r--r-- (I'm the owner of the file) – elyashiv Nov 18 '12 at 11:15
@PhilippeBlayo it's not a permission problem - I run it on root user and got the same result. – elyashiv Nov 18 '12 at 11:30
There were some non-printing control characters in your command that were making it appear strangely on my browser. I have edited it to fix this, please confirm that the command is correct. – Random832 Nov 19 '12 at 13:38
@Random832 the command is correct, thnx. – elyashiv Nov 19 '12 at 14:11
up vote 4 down vote accepted

If you are creating an image of the bin directory, either put your boot image in bin/bin/boot.bin or specify it as boot.bin. The boot image path is relative to the source path (bin).

share|improve this answer
I'm not creating a image of the hull directory, just the file thats in the bin directory. the file is called boot.bin. any way, I trued full paths (/home/<user> etc) and it didn't help, so it's not a directory problem. – elyashiv Nov 18 '12 at 12:44
@elyashiv You are creating an image of the bin directory: mkisofs ... bin. Your boot image path is relative to that directory. If it is right there in bin, you just say -b boot.bin. Do you get it? – angus Nov 18 '12 at 13:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.