Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using a relatively new centos system with Gnome. I have set the keyboard to dvorak, which was really easy and straightforward.

However, for some reason, the control keys are still qwerty. I didn't have this problem with older Gnomes.

ETA: This is only in terminal. emacs works fine.

share|improve this question
    
What's the setting of Preferences->Keyboard->Layouts->"Separate layout for each window"? –  Mikel Nov 17 '12 at 0:20
    
    
Define terminal. Unless you mean "terminal emulator under X Windows", there's no way the GNOME keymap settings would be able to affect the terminal... –  njsg Nov 17 '12 at 10:19
    
Hmm, if you are using the GNOME terminal emulator, it would make sense, as this is probably GTK-based and Emacs is not necessarily GTK-based (although it can (or could) be built with the GTK libraries, which are not required for the X Windows emacs). If this is the weird behavior @Mikel pointed out, that would explain why Emacs works. –  njsg Nov 17 '12 at 10:24
    
@Mikel: I'm musing the same layout for all windows, and it uses dvorak for normal typing, just not modified keys. –  Brian Postow Nov 19 '12 at 19:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.