Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got annoyed with the system beep of Linux Mint Debian Edition when I login or logout. I have found some solutions like:

echo "blacklist pcspkr" | sudo tee -a /etc/modprobe.d/blacklist

but it didn't work for me. How can I turn off the beep?

share|improve this question
You may need to blacklist snd_pcsp as well... – jasonwryan Nov 16 '12 at 6:14
I tried to add blacklist snd_pcsp, but it still doesn't work. – Kesco Nov 16 '12 at 15:26
For that to work, your speaker driver has to be built as a module; here I disable it with modprobe.blacklist=pcspkr in the kernel boot parameters. First, do lsmod | grep pcspkr and check if it returns anything. If it doesn't, then it's not built as a module; if it does and blacklisting does remove it from the list, then maybe the beep is not made through the system speaker? – njsg Nov 16 '12 at 15:59
And I think snd_pcsp is a completely different thing, you want to blacklist pcspkr, which is what provides you the usual beep speaker; I think snd_pcsp is a driver to use that speaker as you would use external speakers (play mp3s, etc); if I am correct, disabling it won't disable the usual beep at all, because it's a separate driver. – njsg Nov 16 '12 at 16:12
Yes, I don't find any driver about snd_pcsp.By the way, how to disable modprobe.blacklist=pcspkr in the kernel boot? – Kesco Nov 19 '12 at 4:36

Well, the easiest is to set setterm -blength, It'll set the beep length to 0.

when it's about X, then I'd advice xset b off, it'll disable the beep in X.

share|improve this answer
The setterm -blength turn off the terminal beep, not the system beep. – Kesco Nov 16 '12 at 15:28
And I often login by mdm. – Kesco Nov 16 '12 at 15:28

From all the tutorials I've found, this is the only one that worked for me:


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.