Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Switch: HP ProCurve 2910AL-48G - J9147A

This switch is brand new straight from HP.

Anyone familiar with ser2net for creating a terminal server to connect from usb>serial>console port on a HP procurve switch? I've done this 4 times in the past couple months and had 0 issues. This exact same new one isn't working.

Guides I used as a reference:
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=115&prodSeriesId=3901671&prodTypeId=12883&prodSeriesId=3901671&objectID=c01975721
http://www.gns3.net/switching-how-to-console-into-your-devices/

root@mycomp:/dev# lsusb
Bus 001 Device 006: ID 0557:2008 ATEN International Co., Ltd UC-232A Serial Port [pl2303]

root@mycomp:/dev# dmesg | grep tty
[ 0.000000] console [tty0] enabled
[ 0.738224] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 0.963603] 00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[16153.422206] usb 1-1.1: pl2303 converter now attached to ttyUSB0
[18163.982680] pl2303 ttyUSB0: pl2303 converter now disconnected from ttyUSB0
[18167.091054] usb 1-1.2: pl2303 converter now attached to ttyUSB0

/etc/ser2net.conf
3002:telnet:0:/dev/ttyUSB0:9600 8DATABITS NONE 1STOPBIT banner

root@mycomp -> telnet localhost 3002
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

ser2net port 3002 device /dev/ttyUSB0 [9600 N81] (Debian GNU/Linux)

Then it just hangs there, doesn't take me to a prompt as it did in the past with other brand new switches. If you type anything you get:

Connection closed by foreign host.

Any ideas on how to troubleshoot this? Also if there is a better way of doing this, feel free to inform me, I have 3 new switches that ideally need to be deployed by end of day tomorrow.

share|improve this question
    
not sure if it's any better, but check out conserver –  sendmoreinfo Jun 6 '13 at 22:20

1 Answer 1

I saw this problem when I enabled HW flow control (RTSCTS) on my configuration line in the /etc/ser2net config file. You can disable this by adding -RTSCTS to the line.

I also had the issue that my session would immediately disconnect with:

Connection closed by foreign host.

I solved this by adding "LOCAL" to the configuration line which ignores the modem monitoring lines.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.