Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I added the following to /root/.config/openbox/rc.xml:

<keybind key="C-A-t">
        <action name="Execute">
            <command>/root/my-applications/test1.sh</command>
        </action>
</keybind>  

The test1.sh file consists of an executable shell script which outputs ñ. The idea being to tie the key combination to the output, so when I press C-A-t it will output an ñ. However, it doesn't work; pressing it in (for example) Geany does nothing. I have reconfigured openbox. What am I doing wrong?

share|improve this question
    
What about X's key compose feature? Enable it then compose-key,n,~ will generate “ñ”. (The Compose key Wikipedia article has some good links at the bottom.) –  manatwork Nov 14 '12 at 16:45
    
Is your script executable? What happens if you change the line for :<command>sh /root/my-applications/test1.sh</command> –  pedrosaurio Nov 15 '12 at 8:50
add comment

1 Answer

First off, why are you running X as root? That's a really bad idea considering all of the security implications.

Secondly, binding a key to a script that outputs "ñ" is not the same as giving that to a program (on the contrary, it likely just goes straight to /dev/null). You need to look into using something like xdotool.

share|improve this answer
    
I'm using puppy linux. I've tried using "xdotool key ntilde" but that doesn't work either. –  ptak Nov 14 '12 at 16:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.