Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to clone 2 displays. I have a laptop with 1440x900 resolution and an external monitor with 1024x768 resolution. I want the laptop screen to show the same as the external monitor however, since the last update I cannot select a lower resolution for the laptop than it's native resolution of 1440x900 in nvidia-settings.

Simply put, I want the laptop screen to display 1024x768 and cloned to the external monitor.

I have looked into xrandr and came to the following commands, however this does not work. I am using the nVidia 302.17 driver at this moment. I have upgraded to 304.48, but the issue remains.

dennisf@anarki:~$ cvt 1024 768 60
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync

dennisf@anarki:~$ xrandr --newmode "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync

dennisf@anarki:~$ xrandr --addmode LVDS-0 1024x768_60.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  153 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  31
  Current serial number in output stream:  32

Further information:

dennisf@anarki:~$ xrandr -q
Screen 0: minimum 8 x 8, current 1440 x 900, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
TV-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+
   800x600        60.0  
   720x480        60.0  
   640x480        60.0  
   640x400        60.0  
   512x384        60.0  
   7936x32636    137.6  
LVDS-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1440x900       60.1*+   60.1  
HDMI-0 disconnected (normal left inverted right x axis y axis)
  1024x768_60.00 (0x277)   63.5MHz
        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock   47.8KHz
        v: height  768 start  771 end  775 total  798           clock   59.9Hz

Thank you.

share|improve this question
    
I assume a plain xrandr --output TV-0 --same-as LVDS-0 (maybe without the -0) fails somehow? –  sr_ Nov 13 '12 at 22:32
    
The TV-0 max res is 1024x768, but LVDS-0 is 1440x900, so that doesn't really work. I can "clone" them in nvidia-settings, but only a part of LVDS-0 is shown on TV-0 (the top right corner, for example). –  InFerNo Nov 13 '12 at 23:46
    
5 minute edit limit: To clarify, here is a screenshot: snag.gy/RQA1M.jpg –  InFerNo Nov 13 '12 at 23:52

2 Answers 2

up vote 0 down vote accepted

This issue has been resolved with the latest drivers 331.20 by nVidia. All resolutions are now selectable from the nvidia-settings.

share|improve this answer

Apparently, nvidia doesn't support xrandr yet.

Thus you could follow the linked page's xorg.conf instructions or give disper a try:

Disper is an on-the-fly display switch utility. [...] Disper gives you the option to either clone all detected displays, or extend the desktop to them. Resolutions are automatically detected. For cloning, the highest common resolution supported by all displays is chosen; [...] At the moment nVidia cards are supported, and a basic XRandR backend is in place.

Disper is packaged for Debian (testing, sid), too. (You could try apt-pinning if you're on stable.)

Edit NVidia's 302 driver has XRandR support. It's in testing/sid, too (but without backports to stable; apt-pinning is probably not an option here).

share|improve this answer
    
I have just upgraded to 304.48. –  InFerNo Nov 15 '12 at 11:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.