Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

All the KDE based editors (Kate, KWrite, Kile, etc.) tend to produce recovery (?) files that are named like the edited file with a tilde at the end. The annoying thing is that these files are left even after I quit the editor. How can I disable this behaviour? I don't mind having these while I am editing (if they help with anything), but I don't want them after I finish.

share|improve this question
    
Just a thought... you may not want to do that. Sooner or later it will hapen that you'll erase or overwrite the file unexpectedly (and that happens usually when you DON'T have the file open). At that point, these are the only ones that can save you. All the *nix editors do that for a reason - better safe than sorry. It's standard to have -B switch aliased in ls so you don't even notice them until you need to find them. –  orion Mar 17 at 19:57
add comment

1 Answer

up vote 4 down vote accepted

Go to Settings > Configure > Editor Component > Open/Save > Advanced, and uncheck the box next to local files under "Backup on Save".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.