Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I try to get smbd running on Linux Mint 13 on kernel 3.6.3-030603-generic. This is what I do:

sudo apt-get install samba, then install this minimal /etc/samba/smb.conf:

[global] 
    workgroup = wkb
    security = user
    browsable = yes 
    local master = yes 
[temp] 
    path = /tmp 
    public = yes 

Then I type: smbclient -L localhost -U% and get the following error:

Domain=[WKB] OS=[Unix] Server=[Samba 3.6.3]
tree connect failed: NT_STATUS_PIPE_BROKEN

What am I doing wrong? How can I debug it further? I can't find the reference to this error message on the Net.

Update:

I put sudo smbpasswd -U Adam and filled in some password.

Then, when I connect to the share from Windows, after filling in username "Adam" and the same password, first I do see the correct share list:

share list

But then, when I try to enter the share "tmp" (to which the user "Adam", spelled with capital "A") has all read/modify rights, I've got the following error message:

error message

It is interesting, that when I subsequently try to refresh the share list this message persists, as if samba had crashed. But the service status smbd insists, that smbd start/running, process 27309...

But it must be a crash of some sort, since at the end of /var/log/samba/log.smbd I can find:

[2012/11/13 10:01:35.281800,  0] lib/fault.c:372(dump_core)
  dumping core in /var/log/samba/cores/smbd
[2012/11/13 10:01:35.296359,  0] lib/util.c:1117(smb_panic)
  PANIC (pid 29359): sys_setgroups failed
[2012/11/13 10:01:35.303973,  0] lib/util.c:1221(log_stack_trace)
  BACKTRACE: 21 stack frames:
   #0 smbd(log_stack_trace+0x1a) [0x7ff64ea37aea]
   #1 smbd(smb_panic+0x25) [0x7ff64ea37bc5]
   #2 smbd(+0x163be6) [0x7ff64e782be6]
   #3 smbd(set_sec_ctx+0x8f) [0x7ff64e782f0f]
   #4 smbd(+0x152db5) [0x7ff64e771db5]
   #5 smbd(+0x17ae2b) [0x7ff64e799e2b]
   #6 smbd(+0x17b76e) [0x7ff64e79a76e]
   #7 smbd(make_connection+0x1ea) [0x7ff64e79aaea]
   #8 smbd(reply_tcon_and_X+0x1dc) [0x7ff64e74b82c]
   #9 smbd(+0x176fa4) [0x7ff64e795fa4]
   #10 smbd(+0x1773bb) [0x7ff64e7963bb]
   #11 smbd(+0x1777d3) [0x7ff64e7967d3]
   #12 smbd(run_events_poll+0x34e) [0x7ff64ea478ae]
   #13 smbd(smbd_process+0x812) [0x7ff64e797f42]
   #14 smbd(+0x68666f) [0x7ff64eca566f]
   #15 smbd(run_events_poll+0x34e) [0x7ff64ea478ae]
   #16 smbd(+0x428a4a) [0x7ff64ea47a4a]
   #17 smbd(_tevent_loop_once+0x90) [0x7ff64ea485d0]
   #18 smbd(main+0xed0) [0x7ff64e716030]
   #19 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed) [0x7ff64b5c176d]
   #20 smbd(+0xf7515) [0x7ff64e716515]
[2012/11/13 10:01:35.305623,  0] lib/fault.c:372(dump_core)
  dumping core in /var/log/samba/cores/smbd
share|improve this question

3 Answers 3

up vote 1 down vote accepted

Problem solved upgrading to samba 3.6.7

https://www.monlore.nl/blog/?p=226

share|improve this answer

Check if daemon started:

sudo service smbd status

Then check log files in /var/log/samba

share|improve this answer
    
Thank you. No. It is running, otherwise it would respond with Connection to localhost failed (Error NT_STATUS_CONNECTION_REFUSED) and not with NT_STATUS_PIPE_BROKEN. The sudo service smbd status gives smbd start/running, process 29290 –  Adam Ryczkowski Nov 13 '12 at 8:48
    
I've added the crash log. It seems the samba crashes... –  Adam Ryczkowski Nov 13 '12 at 9:06
    
This problem seems to be related to the groups the user is member of. How many of them are? –  Laurentiu Roescu Nov 13 '12 at 10:05
    
None. The user Adam is not a member of any group. Should he be one?... –  Adam Ryczkowski Nov 13 '12 at 11:25
    
to be sure run the command 'groups Adam' –  Laurentiu Roescu Nov 13 '12 at 11:29

It is the problem with 3.6.3 , I am not happy with ubuntu server , it lost me a day to find what is the problem. I upgraded to 3.6.7 and it fix everything !!! Ubuntu server is going to worse every new version !

share|improve this answer
1  
It was enough to state that updating fixed your problems, and it would have been nice to detail which ones. –  vonbrand Mar 6 '13 at 9:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.