Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm doing the following to mount a remote server to a specific path on my server:

sshfs user@remoteserver.com:/backup/folder/ /home/myuser/server-backups/

However when I mount the server the folder permissions change (they become 700), and when I test my rsnapshot.conf file I get the following error:

snapshot_root /home/myuser/server-backups/ - snapshot_root exists \
         but is not readable

What am I doing wrong ? should I mount the remote server with another user ?

share|improve this question
    
Cross-posted at Ask Ubuntu, Unix Stack Exchange and Server Fault. Please hyperlink your questions when you cross-post so that people can find all answers, and don't waste time posting similar answer independently. –  Gilles Jan 8 '11 at 20:31

1 Answer 1

up vote 2 down vote accepted

FUSE has options to control who has access to the files. I'm guessing you want sshfs -o allow_other.

share|improve this answer
    
ok thanks. One more question, Will the remote server be mounted forever ? I mean, until reboot ? –  Patrick Jan 9 '11 at 9:05
    
Uhm it worked with allow_root instead. But then I got permissions error with rsnapshot tool.. but this is not related to this question. –  Patrick Jan 9 '11 at 9:19
    
@Patrick: As with any mount, it will remain mounted until you unmount it, or of course until a reboot. –  Gilles Jan 9 '11 at 11:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.