Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

At home I am connected to network 'A' and can see WLANs 'B' and 'C' from my neighbours.

I suspend my computer and when I get to work the next day, the system still thinks it's connected to the same network 'A' and that it still can see the 'B' and 'C' networks, even though they aren't there.

It will stay there forever trying to connect to the 'A' network, until it's stopped and I select the correct network.

It is not a major problem (I can just open the list of networks and connect to the correct one), but is quite annoying.

It is like (but is different) this bug: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/893316 (in the bug, the system connects to a different WLAN even though the previous one is still available; with my case it's the opposite).

I think it's a NetworkManager problem, because I never saw it when I used wicd. What can it be?

I'm using x86-64 Arch Linux, NM, Intel Wireless 1030 card (iwlagn module).

share|improve this question
Do you have pm-utils installed? In my Debian system this is solved by the script /usr/lib/pm-utils/sleep.d/55NetworkManager. There's a good article on Arch Wiki for pm-utils: wiki.archlinux.org/index.php/Pm-utils – Teresa e Junior Nov 11 '12 at 19:54
This is a bug report. You should send it to Ubuntu, not here. – camh Nov 11 '12 at 21:52
@camh I decided to ask here in case I was missing something or had overlooked solutions. If can't fix this, will report a bug – Renan Nov 11 '12 at 21:57
I tried putting /usr/lib/pm-utils/sleep.d/55NetworkManager from a Ubuntu system into my Arch system and didn't work, too. – Renan Nov 16 '12 at 16:06

Sounds like this old issue: http://blogs.gnome.org/dcbw/2009/02/26/suspendresume-vs-networkmanager/

If you're running an old kernel, upgrading would fix it. Otherwise, maybe the bug has come back in some form (in which case it should be reported, either to network-manager or to the upstream driver guys)

share|improve this answer
I am using kernel 3.5.6 (kernel 3.6.0 and beyond causes power management problems - cf. unix.stackexchange.com/q/53213/15630), and the link you post talks about kernels 2.6.30. But I tested with Ubuntu (kernel 3.5.0) and the problem doesn't happen there. So seems this is not the case. – Renan Nov 11 '12 at 21:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.