Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

From this answer the solution is to

modprobe loop max_loop=64

Which makes me allowed to use 64 loopback devices then

mknod -m 660 /dev/loop8 b 7 8

To create the devices. I did this for 8, 9, 10 and 8,9 works but 10 does not.

I then tried loopa to loopf and tried to mount a 11th device and i get the error

Error: Failed to set up a loop device:

How do I make >10 loop devices?

share|improve this question
Make sure you are running mknod -m 660 /dev/loop10 b 7 10. It worked fine for me. What distribution are you using? – sparticvs Nov 10 '12 at 6:11
@sparticvs: oops, I have been using 8 as the last value for all vars. I wonder why it let me mount my 9th and 10 device if i did it incorrectly. I use ubuntu, i'm testing right now. yep it worked. I'll accept if you answer – acidzombie24 Nov 10 '12 at 6:23
You can make multiple filesystem entries for the same device. They all designate the same device. You got this error when you called losetup or mount -o loop on a loop device that's already in use (even if you reach that device through a different name). – Gilles Nov 10 '12 at 22:38
up vote 11 down vote accepted

Make sure you are running mknod -m 660 /dev/loop10 b 7 10. The format is mknod -m 660 /dev/loop<ID> b 7 <ID> where ID is the same.

Update [07/10/2014]

I also found a good blog post to always have more at boot. See https://yeri.be/xen-failed-to-find-an-unused-loop-device

Update [05/25/2016]

I run a CentOS server, and I found that this post was also helpful when the other methods don't work.

This makes my new favorite method:

MAKEDEV /dev/loop

It creates 256 loop devices (which is the max without modifying the kernel).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.