Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to disable consoleblank and activates console clock vcstime which are obviously managed by kbd on my Debian 6. So I've changed the following in /etc/kbd/config file:

  • POWERDOWN_TIME=1
  • BLANK_TIME=1
  • DO_VCSTIME=yes

But theses settings aren't taken into account (knows it because the clock doesn't appears) after a:

# /etc/init.d/kbd restart
Setting console screen modes.
Skipping font and keymap setup (handled by console-setup).
# /etc/init.d/console-setup restart

What is the correct way of changing kbd configuration and activates it without rebooting?

Edit: Indicates version used :

  • Debian 6 "Squeeze" v6.0.6
  • kbd package v1.15.2-2
  • console-setup package v1.68+squeeze2
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Take a look at the setup() function in /etc/init.d/kbd. It does a number of checks, like requiring that you're running /etc/init.d/kbd restart inside a virtual console before it starts vcstime. My guess is that you're starting it from within an xterm, via ssh, in screen, or something similar so it doesn't have direct access to your console.

share|improve this answer
    
You're right, I was using a remote computer to restart kbd: When doing it from a virtual console, clock appeared and consoleblanking stopped. I'll accept this answer because it fixed my issues. –  CDuv Nov 10 '12 at 12:21
    
On a side note: I can't disable the clock. Reactivating the consoleblank (by editing /etc/kbd/config) and restarting kbd works but not the vcstime. When restarting kbd (even tryed restarting console-setup) the clock does disappear but only until I run another command (any command: eg. ls), then the clock is again shown. –  CDuv Nov 10 '12 at 12:51
1  
sudo killall vcstime will probably fix it. –  Jim Paris Nov 10 '12 at 15:12
    
You were right: several vcstime processes were running. Killing them made the clock stopped, then restarting kbd cleared it from console. Thanks again :) –  CDuv Nov 10 '12 at 17:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.