Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am on Fedora 16 KDE spin. Yesterday I ran the fsck command and that broke things. I can login via the tty, so I guess it has nothing to do with the shadow file. The login screen reappears after login no matter how many times I try to get past it. The permissions are the same as before. Also I have tried renaming the .kde folder. Doesn't help. This affects all the users, even root. My guess is the X server is restarting after login bringing me back to the login screen. Any way I can solve this?

share|improve this question
I think you should start by looking at ~/.xsession-errors and /var/log/messages – Joseph R. Nov 8 '12 at 9:18
also /var/log/Xorg.1.log – xenoterracide Nov 8 '12 at 16:25
Can you log in if you do single user mode? If you can't then your /etc/shadow file might be borked. – sparticvs Nov 8 '12 at 18:17
You can also try to start X from sommand line with startx optionally redirecting its stdout and stderr: startx 2>startx.err 1>startx.log – peterph Nov 8 '12 at 20:17
sorry for the late reply. It was the X server indeed. I followed what peterph said and the startx.err file had this, /usr/bin/ssh-agent: error while loading shared libraries: libfipscheck.so.1: cannot open shared object file: No such file or directory. xinit: connection to X server lost. I have no idea what that means. I tried disabling ssh but it doesn't help. – Phani Kumar Nov 9 '12 at 9:35
up vote 1 down vote accepted

Given your answers in the comments, the problem is that the program "ssh-agent" can't load the library libfipscheck which it needs in order to run. The quick fix is to edit your .xinitrc file and comment out the call to ssh-agent from it. The real fix is to re-install the package fipscheck-lib .

share|improve this answer
Amazing! That did the trick. It was the /etc/X11/xinit/xinitrc-common file that had the SSH-AGENT line. – Phani Kumar Nov 9 '12 at 15:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.