Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using the XfApplet for integrating the mintMenu into my Mint Xfce installation.
As shortcut I defined Super_L which works fine.
Additionally I want to define a shortcut <Super_L>r to execute gnome-terminal.
Unfortunately the Super_L keystroke gets interpreted and consumed early so that the mintMenu appears and types r into the search field.

Is it possible to configure that both shortcuts Super_L and <Super_L>r work properly?

Edit: This is how the mintmenu looks like.
enter image description here

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I'm afraid not entirely - the events seem to be activated on key-press (as opposed to key-release), hence the best you will likely be able to achieve is Super_L opening the menu, and if you don't let go of the key and press r being interpreted as Super+r, which would open your terminal (at least how this works for me).

share|improve this answer
    
So you created two shortcuts via the keyboard menu, right? How can I open the mint menu via the shell? I tried mintmenu but this simply spawns the menu button in the middle of the screen. Am I missing some parameter? Currently I only configured the menu shortcut in the panel's preferences not via the keyboard shortcut configuration.. –  user1563 Nov 6 '12 at 22:11
    
@user1563 Yes, two shortcuts, but the one for plain Super_L is triggered always. I'm not really sure what mintmenu is - any chance xfce4-popup-applicationsmenu might be what you are looking for? By the way, would it be suitable to use the Menu key to open the menu? –  peterph Nov 6 '12 at 22:35
    
Since I'm using both Windows and Linux on different machines I want to configure the same shortcuts for convenience. The xfce4-popup-applicationsmenu command opens the context menu of my mouse which is not what I'm looking for. I've added a screenshot of the mint menu. I changed the shortcut to <Control>Super_L which is less convenient but works at least. Thanks for your effort. –  user1563 Nov 7 '12 at 7:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.