Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Ok I'm pulling my hair out over this one. We have a wireless network with many clients all working well except two Ubuntu clients running 10.10 that can't access the internet via a browser at the same time. They can both still ping, use Skype etc but can't browse.

As soon as the one that can browse exits the network browsing returns for the other and vice versa. As ping and Skype was working I assumed some kind of DNS problem but moving over to OpenDNS didn't solve it, nor did restarting networking or using wired rather than wireless.

We also switched out the router, and it still persisted so I'm sure this isn't a network issue. The two clients are both laptops and work fine together on a wireless network at another office (which we don't control).

I'm thinking something must be cached from the other network they both use that's causing this but have no idea what.

Does anyone have any ideas? I just don't know where to go from here.

share|improve this question
1  
Not too knowledgeable on networking, but have you tried setting the IP statically? Have you also connected one of them on a LAN cable and see if the problem persists? –  Tshepang Jan 7 '11 at 10:28
    
My wild guess: Can you make sure that the hostnames and IP addresses are unique? Also, can you try "browsing" using wget? –  phunehehe Jan 8 '11 at 4:19
    
@phunehehe: Now that you mention it, these are exactly the symptoms of two machines having the same IP address. When one sends packet, some switch decides “hey, 1.2.3.4 is now on my left port”, and keeps this information in cache for a while. You should make this an answer. –  Gilles Jan 8 '11 at 18:32

3 Answers 3

From the packet dump, it looks like Wireshark thinks that a number of frames are not in Ethernet v2 format. A guess could be that one of the laptops is bonding two 54mbps channels into 108mbps using 802.3ad channel bonding (called Super-G mode when it's over WiFi in the original Atheros implementation, D-Link licensed the technology and probably called it something else) and that this is somehow failing.

Notably, a few packets are sent in normal framing format, namely DNS traffic, which also happens to work fine.

One idea could be to disable Super-G on either or both sides and see how that turns out.

Also, a raw dump rather than ASCII for machine2 would be nice ;-)

share|improve this answer

My guess is, those two machines share something that should have been unique. You should check their hostnames and IP addresses, then change them appropriately.

share|improve this answer
    
That's exactly what I thought, but they can both join the network in another office (different location) without any problems. I think I'm just going to format one and see if that fixes it. –  ChrisInCambo Jan 10 '11 at 6:33

Difficult to say, given the limited amount of information available. Here's a couple of random suggestions.

  • Check that proxy settings are correct (similar to working laptops).

  • Check that Proxy Auto-Discovery works the same for your two browsers, as it does for browsers on other laptops on the same network. Auto-discovery happens via DNS in Firefox, Internet Explorer supports both DNS, DHCP (via an INFORM request for option 252) and Group Policy distribution of proxy settings. (Maybe IE supports one additional method, I can't recall at the moment.)

  • Use a sniffer like tcpdump or Wireshark to figure out exactly what is going on. If you're not sure how to interpret the raw packets, the additional information might be useful to add to this question.

share|improve this answer
    
Sorry for the slow response user3487. I just used Wireshark to have a closer look at what's going on. We turned both machines on and pointed them both to the same website. The content loaded on one and not the other. Here is the output from wireshark- (speedyshare.com/files/26228631/machine_output_1 && speedyshare.com/files/26228649/machine2). As you can see the first one worked, the second one didn't. –  ChrisInCambo Jan 13 '11 at 5:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.