Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I've switched from Fedora 17 to OpenSUSE 12.2. I used to add my proxy from Network Settings>Network Proxy>Manual Method>Socks Hosts. But it doesn't work on openSUSE.

I get the following error in Chrome:

Error 120 (net::ERR_SOCKS_CONNECTION_FAILED): Unknown error.

Further more proxy setting at Gnome Config Editor is not applied at all.

I know that I can use proxy at software level (like firefox) but then I have to set the proxy for all of my application and some application doesn't support that.

share|improve this question

Go to 'Applications' tab at the right select 'System Tools' click on 'YaST' enter the root password and then you will find an icon 'proxy' click on it and complete the form.

Hope this help you.

greetz, Tony

share|improve this answer
unfortunately yast's proxy doesn't support socks, but it works great with http and https! – neelix Nov 30 '12 at 9:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.