Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Debian 6 . Now I don't understand why it says PHP 5.3.18 is the latest when 5.3.2 has been around for 2 years? I need at least PHP 5.3.2 for my symfony project. Thanks.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

PHP uses the dotted integer convention for versions (i.e. the version number should be considered a sequence of integers, not a floating point number). 5.3.10 was the release after 5.3.9. That means 5.3.18 is sixteen releases after 5.3.2.

Note that this is the standard way of interpreting a version number with more than one dot in it. Single-dotted version numbers are less consistent. Some projects consider them a floating point number, and some treat them as a pair of integers.

share|improve this answer
add comment

5.3.18 is more recent than 5.3.2.

As a sidenote, you should probably go straight to PHP 5.4 if you don't have any hard dependencies on 5.3.* The short array syntax is a good enough reason for me.

share|improve this answer
    
APC depends on it –  Marin Nov 6 '12 at 16:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.