Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have my Wacom Bamboo tablet working fine under Fedora 14 but would like to switch it from right- to left-handed.

How can this be done?

share|improve this question
What do you mean by left-handed? You want applications on the right and shutdown on the left? – phunehehe Jan 6 '11 at 16:04
I mean write on the tablet using my left hand with all the tablet buttons on the right-hand side (so they're not pressed accidentally). – Nick Pierpoint Jan 7 '11 at 11:36
up vote 3 down vote accepted

Use xsetwacom.

Basically, you'll want to list your current configuration, then re-configure the buttons to be the opposite way around, e.g. what button 1 did, button 4 should be (or whatever).

You could also try using xinput.

Something like:

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Wacom Bamboo 2FG Finger pad               id=11   [slave  pointer  (2)]
⎜   ↳ Wacom Bamboo 2FG Finger touch             id=12   [slave  pointer  (2)]

$ xinput get-button-map "Wacom Bamboo 2FG Finger pad"
1 2 3 4 5 6 7

$ xinput set-button-map "Wacom Bamboo 2FG Finger pad" 3 2 1 4 5 6 7

Do you also need to remap the x and y axes?

Final thought: what happens if you go to System->Preferences->Mouse? Maybe changing it to left handed has some effect?

share|improve this answer

Thanks for the above suggestion. It solved a slightly different problem for me:

I configured my regular mouse to be left-handed, and wanted to use the Wacom tablet right-handed. The problem was that the tablet now interpreted pen/touch clicks as 'right-clicks', following the mouse setting - thus displaying the context menus etc.

The following worked:

xinput set-button-map "Wacom Intuos PT S Finger touch" 3 2 1 4 5 6 7
xinput set-button-map "Wacom Intuos PT S Pen stylus" 3 1 2 4 5 6 7

Note: I had previously tried:

"xsetwacom set "Wacom Intuos PT S Pen stylus" button 1 button 3"

-- which did NOT work in my set-up

(using KDE 5.14.0/Wacom Intuos Pen and Touch)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.