Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to build the .rpm package. i have just followed the steps to do that. Till now all step was gone fine but now i just stuck with this step. I just ran the following command and got this error :

rpmbuild -ba asterisk.spec
error: Failed build dependencies: 
    gtk2-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libsrtp-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    gmime22-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    graphviz is needed by asterisk-1.8.12.2-1.fc15.x86_64
    graphviz-gd is needed by asterisk-1.8.12.2-1.fc15.x86_64
    latex2html is needed by asterisk-1.8.12.2-1.fc15.x86_64
    neon-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libical-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    speex-devel >= 1.2 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    gsm-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libedit-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    openais-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    alsa-lib-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    dahdi-tools-devel >= 2.0.0 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    dahdi-tools-libs >= 2.0.0 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libpri-devel >= 1.4.12 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libss7-devel >= 1.0.1 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    spandsp-devel >= 0.0.5-0.1.pre4 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    iksemel-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    jack-audio-connection-kit-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libresample-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    lua-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    mISDN-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    bluez-libs-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    libtool-ltdl-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    unixODBC-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    portaudio-devel >= 19 is needed by asterisk-1.8.12.2-1.fc15.x86_64
    postgresql-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    radiusclient-ng-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    net-snmp-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    lm_sensors-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    freetds-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64
    uw-imap-devel is needed by asterisk-1.8.12.2-1.fc15.x86_64

I am using fedora-15. How to resolve this error? Any idea and suggestion will be appreciated
Thanks

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Just install these devel packages,

yum -y install alsa-lib-devel bluez-libs-devel dahdi-tools-devel dahdi-tools-libs freetds-devel gmime22-devel graphviz graphviz-gd gsm-devel gtk2-devel iksemel-devel jack-audio-connection-kit-devel latex2html libedit-devel libical-devel libpri-devel libresample-devel libsrtp-devel libss7-devel libtool-ltdl-devel lm_sensors-devel lua-devel mISDN-devel neon-devel net-snmp-devel openais-devel portaudio-devel postgresql-devel radiusclient-ng-devel spandsp-devel speex-devel unixODBC-devel uw-imap-devel 

If this package belongs to standard repository, use yum-builddep XXX instead. (need to install yum-utils first)

share|improve this answer
    
Can i install this packages during installation of rpm? i want to preinstall all the dependency. –  juned Nov 5 '12 at 6:53
    
@juned those are required for building the binary RPM, not installing it. Yum can handle resolving depends on installation. –  jordanm Nov 5 '12 at 6:54
    
@jordanm i can resolve this error by installing this missing packages in my system but what if i run same rpn package in other system. –  juned Nov 5 '12 at 6:57
    
@Warlock can i install those dependencies using spec file. i want to pre-install all those dependency. like if we install asterisk using yum install asterisk then why it doesn't give this kind of error and automatically installs dependencies –  juned Nov 5 '12 at 7:03
    
@juned build dependencies are not needed for you to run an application, but for you to build an app –  warl0ck Nov 5 '12 at 7:12
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.