Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently purchased an SMTP server for my web app (I need to send account confirmation emails to my users and I don't want them to go into the SPAM folder, I will also be using it for email marketing.) and I'm following a guide found on this website. http://syslog.tv/2011/09/15/postfix-dovecot-imapimaps-sasl-maildir/ How ever when I go to restart all the applications I get two errors.

    Restarting IMAP/POP3 mail server: dovecotError: Error in configuration file /etc/dovecot/dovecot.conf line 892: Expecting '='

I have looked at the file and nothing seems out of place, is there anything that I'm doing wrong here?

auth default {
   mechanisms = plain login

   passdb pam{
   }
   userdb passwd {
   }
   socket listen {
client {
    path = /var/spool/postfix/private/auth
    mode = 0660
    user = postfix
    group = postfix
    }
   }
}

And the other error I recieve is when I try to restart POSTFIX Stopping Postfix Mail Transport Agent: postfixpostfix: fatal /etc/postfix/main.cf, line 47: missing '=' after attribute name: "permit_mynetworks,"

My code is

    home_mailbox = Maildir/
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_local_domain = $myhostname
    broken_sasl_auth_clients = yes

    smtpd_sender_restrictions = permit_sasl_authenticated,
    permit_mynetworks,

    smtpd_recipient_restrictions = permit_mynetworks,
    permit_sasl_authenticated,
    reject_unauth_destination,
    reject_unknown_sender_domain,

Any help at all would be appreciated, I've been havign trouble trying to find any help on trying to set up my SMTP server

-Greg

share|improve this question
    
Check for line wrapping problems. Either put each configuration option on a single line, or add white space on the continuations lines. – Philippe Gauthier Nov 5 '12 at 3:26
    
If you could paste the config file with line numbers, it might make it a little easier to troubleshoot. – Mark Cohen Nov 5 '12 at 3:29

In your Postfix config, permit_mynetworks needs at least one space or tab before as it is not a configuration directive, it is only an option.

smtpd_sender_restrictions = permit_sasl_authenticated,
    permit_mynetworks

or

smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks

both would work. If it starts at the beginning of a new line, Postfix waits for something like key = value.

Your dovecot problem could be something similar. Possibly a Problem with a line before or after that configuration block you posted.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.