Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running a version of RHCE6 on my laptop, and lately I've been trying various stuff about network configuration through command line. Last night, I tried removing the NetworkManager using "yum remove NetworkManager" from the system, so that I could have more control of the network through the command line. But the result is, I didn't manage to configure the wireless connection through wpa_supplicant, and I need wireless connection during my travel to another place. So I need the wireless function back as soon as possible. I typed " yum install NetworkManager", some version installed, but I don't get to have an icon on the taskbar, and of course, the network doesn't work. The package I previously removed(about 24MB) was much larger that the one I just installed(about 2MB), so I think some dependencies must be missing. How could I install all these dependencies? Please help!

share|improve this question
add comment

migrated from serverfault.com Nov 4 '12 at 2:37

This question came from our site for professional system and network administrators.

1 Answer

Did you check the Wiki page for NetworkManager

Install :

yum install NetworkManager

Check if running or Start if not:

service NetworkManager status

Start if it's not running:

service NetworkManager start
chkconfig NetworkManager on

Disable network and wpa_supp services as stated in Wiki:

chkconfig network off
chkconfig wpa_supplicant off

And Reboot. To open it's GUI:

nm-applet
nm-connection-editor

UPDATE 1:Check out Reinstall all dependencies of a given package?

share|improve this answer
    
Thank you for the answer. I've run all the commands you listed, still no avail. Opening the GUI using nm-applet and nm-connection-editor would return "command not found". –  Yang Jy Nov 3 '12 at 8:12
    
Check with yum whatprovides */nm-applet and yum whatprovides */nm-connection-editor what packages you need to install as well. –  Alexander Janssen Nov 3 '12 at 8:22
    
@YangJy Updated my answer. –  xperator Nov 3 '12 at 8:39
    
@alexanderJanssen thank you for the comment, as now I have no Internet access on the laptop in question, I'll check your commands later. :) –  Yang Jy Nov 3 '12 at 10:45
    
@xperator Thank you again, it really helps :) –  Yang Jy Nov 3 '12 at 10:45
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.