Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am building RPMs using FPM. When using the --rpm-user and --rpm-group, I notice as advertised that in the specfile that the %defattr(-,user,group,-) is set under %files.

This does indeed set the user and group settings of files, but how do i set the directory user & group?

share|improve this question

migrated from serverfault.com Nov 4 '12 at 2:08

This question came from our site for system and network administrators.

    
Related: github.com/jordansissel/fpm/issues/245 –  JavaRocky Sep 25 '12 at 5:55
    
Does the recently-added --directory flag for FPM solve the problem? See github.com/jordansissel/fpm/blob/master/CHANGELIST and github.com/jordansissel/fpm/pull/260 –  Lars Rohrbach Nov 15 '12 at 6:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.