Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Ubuntu Server 12.10. I am using openbox and startx for my gui session. I decided not to post in the Ubuntu forum because I felt this issue might be relevant to other distros as well, especially Debian based ones.

I installed firefox and flashplugin-installer so I could watch youtube videos. The videos seem like the work fine, however, I seem to be without sound.

I also got volumeicon-alsa and alsa-utils but when I run alsamixer I get:

cannot open mixer: No such file or directory

when I try to run volumeicon I get

volumeicon: alsa_backend.c:86: asound_get_volume: Assertion `m_elem != ((void *))' failed.

I don't mind using something other than alsa if I need to. I would just like to know what packages I need to install to be able to get sound on youtube videos.

share|improve this question
up vote 2 down vote accepted

First get the available sound card device list by:

aplay -l

Then you can create either ~/.asoundrc or /etc/asound.conf ( go with the second one, then it will be set for every user on the machine ) with the default device settings. So write into one of this files accordingly to the output of the first command. For example my output was:

card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
- Subdevices: 1/1
- Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
- Subdevices: 1/1
- Subdevice #0: subdevice #0

See the lines I made bold? That is the line for my soundcard, so I use that data to enter into my /etc/asound.conf:

defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1

Do this for yourself (use all three configuration option), and dont forget to login/logout.

share|improve this answer
Thanks but aplay -l resulted in aplay: device_list:252: no soundcards found... – math4tots Nov 3 '12 at 18:32
Maybe you don't have the permission on your user to do this, we can test this, go into "root-mode": sudo -i, login, and try aplay -l again. – p1100i Nov 3 '12 at 18:40
Thanks! I also had to run adduser <me> audio, but now it works just fine. – math4tots Nov 3 '12 at 18:53
Ye, that was my next advice going to be [:. Glad for helping! – p1100i Nov 3 '12 at 18:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.