Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install CentOS 5.6 in My VirtualBox but I got this error on boot screen.

Your CPU Does not support long mode : use a 32 bit Distribution

My CPU is 64 bit I checked that using uname -a command and the output is

Linux localhost.localdomain 2.6.43.8-1.fc15.x86_64 #1 SMP Mon Jun 4 20:33:44 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

As per my knowledge I need to enable 32 bit support to my VirtualBox but I don't know from where I can enable that.

If you have any idea regarding this then please suggest me.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You're running a 64bit centos in your VM, but you only get one cpu introduced, try increase the CPUs to at least 2,

enter image description here

share|improve this answer
    
Thanks, in my VM it seems disable i am unable to increase the CPU. it says you need hardware Virtualization support –  juned Nov 3 '12 at 6:40
    
@juned output of cat /proc/cpuinfo ? –  warl0ck Nov 3 '12 at 7:07
    
Can you enable hardware virtualization in your bios? –  jmort253 Nov 3 '12 at 7:07
    
@jmort253 i didn't enable hardware virtualization in my system –  juned Nov 3 '12 at 7:10
    
@warl0ck here is my output of cat /proc/cpuinfo procinfo.txt –  juned Nov 3 '12 at 7:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.