Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After several attempts, I have managed to compile GNURadio on the Raspberry Pi. However, I am just not able to meet the prerequisites for the gnuradio build script on the Pandaboard (Linaro 12.04) or the BeagleBoard (Ubuntu 12.04)

This is what I see -

Failed to find package 'libqwtplot3d-qt4-dev' in known package repositories
Perhaps you need to add the Ubuntu universe or multiverse PPA?
see https://help.ubuntu.com/community/Repositories/Ubuntu
exiting build

I have tried adding all kinds of repositories to get this to work. What repository do I get libqwtplot3d-qt4-dev from for the armhf architecture? Can I mix armfh and armel packages?

share|improve this question
1  
Re "Can I mix armfh and armel packages?" -- unix.stackexchange.com/q/60282/4319 –  imz -- Ivan Zakharyaschev Jan 4 '13 at 12:14
add comment

2 Answers

up vote 3 down vote accepted

That package isn't int the Ubuntu repositories for armel or armhf (at least according to packages.ubuntu.com -- you can probably compile the source package (qwtplot3d). It looks like that package is in universe, so you'll need that enabled.

You should be able to run

apt-get build-dep qwtplot3d
apt-get source qwtplot3d
cd qwtplot3d-*/
dpkg-buildpackage

and get .debs for what you need.

(If the last step fails, then the package needs some porting to work/compile on ARM -- either go nuts, or abandon all hope, depending on how much C++-fu you've got at the moment).

share|improve this answer
    
This mostly worked :-( The last step did not though! I get some errors of redifined data types and pointers that cannot be converted! –  Lord Loh. Nov 4 '12 at 20:54
    
@Community: oops. I had not seen the edit and forked this question into a new question. ( unix.stackexchange.com/questions/55121/… ) –  Lord Loh. Nov 7 '12 at 18:17
add comment

I faced the same problem, however as I am interested to run some C++ scripts using gnuradio platform in pandaboard, I disabled 'libqwtplot3d-qt4-dev' pckg dependency in gnuradio build script. After this step I installed successfully GNU Radio.

Until this time GNU Radio is working ok to me.

I have tested some basic examples in GNU Radio Companion and it works OK.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.