Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a system running Debian 5.0 that doesn't respond to Ctrl-Alt-F# (1-6)

Check if Ctrl, Alt, F1 and F2 are intercepted correctly...

$ DISPLAY=:0 xwininfo

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0xe00002 (has no name)
...

$ xev -display :0 -id 0xe00002
KeyPress event, serial 16, synthetic NO, window 0xe00002,
    state 0x10, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,

KeyPress event, serial 16, synthetic NO, window 0xe00002,
    state 0x10, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,

KeyPress event, serial 16, synthetic NO, window 0xe00002,
    state 0x10, keycode 67 (keysym 0xffbe, F1), same_screen YES,

KeyPress event, serial 16, synthetic NO, window 0xe00002,
    state 0x10, keycode 68 (keysym 0xffbf, F2), same_screen YES,

..They are.

However, xev does not report Ctrl-Alt-F1 as one single event. Does that mean, X does not correctly interpret that sequence?

Check if X is configured to ignore Ctrl-Alt-F#..

$ grep -i dontvtswitch /etc/X11/xorg.conf

..It isn't

But killing X with Ctrl-Alt-Backspace allows me to switch ttys.

The Xorg.0.log at pastebin.

How enable tty switching when running X?

The root filesystem is mounted as read-only. Can that affect how x setups up keyboard mappings? Tried mounting as read-write but the problem persists. Haven't been able to make the system boot up in read-write (I've set the boot options in the bootloader but something happens during boot that remounts the rootfs as readonly).

share|improve this question
    
"Check if Ctrl, Alt, F1 and F2 are intercepted correctly..." ... that's not really how you check it... You should hit CTRL+ALT+F1 and xev output should have something like: state 0xc, keycode 67 (keysym 0x1008fe01, XF86Switch_VT_1) –  don_crissti Nov 3 '12 at 21:41
    
@don_crissti: I've updated my question. Ctrl-Alt-F1 is not reported as one Keypress event, but as three. Do you know where I can find more info on how the X keyboard mapping is handled? –  dannas Nov 5 '12 at 8:26
    
xev output for Alt_L and Control_L is OK (single key press) but instead F1 you should have XF86Switch_VT_1. I'd start with the errors in your Xorg.0.log related to XKB... Make sure you have xkbcomp installed (whatever they call it in Debian) and investigate further. –  don_crissti Nov 5 '12 at 18:39
    
Got this fixed, I presume? Care to share the solution in form of an answer to your own question? –  vonbrand Jan 24 '13 at 18:35
    
I've seen this happen with some keyboards that emulate multiple input devices to achieve n-key rollover. Since the keys are not received from the same device, it does not switch VC. –  Chris Down Apr 4 at 2:25

1 Answer 1

Had the same with Microsoft Natural Keyboard 4000. The answer was surprisingly simple. This keyboard had, either by default or my sloppiness, F-Lock enabled. The key presses of F1-F12 were treated as 'Help', 'Undo', 'Redo', 'New' (and so on) actions. Pressing F-Lock (right to F12 key) deactivated function lock, restoring original function keys assignments.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.