Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to get my zsh to look something like this: https://bbs.archlinux.org/viewtopic.php?pid=1068202#p1068202.

Whenever I print the

└───╼
part of the PS1 to my terminal (or in the .zshrc for that matter). I get question marks (i.e. ??????) or a sequence of â.

I guess this has to do with the character encoding? I have also tried this in urxvt (which as I would suspect would have no problem with this). I also tried changing the font with no results.

share|improve this question
2  
Your issue is likely a misconfigured locale... –  jasonwryan Nov 2 '12 at 0:21
    
afaik, I'm using en_US.UTF-8. (I'm an archlinux user) –  Silverrocker Nov 2 '12 at 0:23
    
Step through the Wiki page I linked to: it is straightforward to correct. –  jasonwryan Nov 2 '12 at 0:23
    
this worked, Thanks! –  Silverrocker Nov 2 '12 at 0:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.