Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Upgrading from a OpenSUSE 12.1 installation with a working FreeNX server, I hit an issue with the FreeNX server on OpenSUSE 12.2, running Gnome 3.

Whenever I connect, I pass the dreaded connection phase (where I've hit most of my issues with FreeNX), and see the client prepare the display, and even see a bit of the display load. But, immediately after this, the NX client will close and show me the error:

The connection with the remote server was shut down. Please check the state of your network connection.

Now, I know my connection, to the network, at least, doesn't have any problems. It seems like the initialization of the X session in the FreeNX connection crashes the display.

The question: How do I successfully connect with an NX client to my FreeNX server?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

From the OpenSUSE forums, I found that the new openSUSE 12.2 Gnome 3 GUI uses fancier features, which cause the GUI to crash over the network.

To fix this, I have to insert an option into the AGENT_EXTRA_OPTIONS_X option in my /etc/nxserver/node.conf file. My original node.conf file actually had nothing in it (no un-commented lines), but I found a commented line for AGENT_EXTRA_OPTIONS_X on line 548. I changed it to:

AGENT_EXTRA_OPTIONS_X="-norender"

And this now enables me to see a GUI successfully when I connect with my NX client to my FreeNX server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.