Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I normally prefer my system to boot in text mode and manually start Gnome with startx but if I do that with Gnome 3.6.1, I get many errors and a basically unusable operating system. After installing gdm however, Gnome works perfectly fine again. Why is that and how can I return to my startx?

Detailed explanation:

I use archlinux and after a system update this morning (2012-11-1) with pacman -Syu which upgraded my Gnome to 3.6.1 I could not successfully boot Gnome 3 anymore. The graphical user interface was there but there was an error message like "There was an error, all extensions are deactivated" and I could not focus windows other then the first one created and the window title bars at the top were not there anymore. I changed my .xinitrc from ck-launch-session gnome-session to exec gnome-session because I've read somewhere that this is necessary now but I got exactly the same error. Only after installing gdm and I think enabling it with systemctl enable gdm does Gnome work correctly again.

share|improve this question
    
I don't Know about archlinux, but the debians have a Set of scripts in /etc/X11/xsession.d/ which construct the command to Start your Desktop Environment. You could Peak in there to See how gdm launches Gnome 3 and steal that command. –  Bananguin Nov 1 '12 at 22:47
    
OP, is this question still a problem for you? if so, you should give an error log, not just a description. –  strugee Dec 1 '13 at 23:34
    
@strugee: Sorry, I did just use gdm from that point on and changed my pc, so that I cannot reproduce the error log and cannot verify the answers but I will mark the one from jason as I guess it will work. –  kirdie Jan 20 at 10:41

2 Answers 2

up vote 1 down vote accepted

If you don't want to use a display manager and you do want systemd/logind to correctly activate your session, you need to endure that you start X in the same TTY that you login on.

See troubleshooting session permissions on the Arch Wiki for the details, but essentially it means ensuring you source the correct xinit scripts in your .xinitrc and you start X with:

[[ -z $DISPLAY && $XDG_VTNR -eq 1 ]] && exec startx

As the wiki notes, you can replace the -eq 1 comparison with one like -le 3 (for vt1 to vt3) if you want to use graphical logins on more than one VT.

share|improve this answer

Try using:

 startx -- vt0

See also this Unix.SE question regarding startx and Fedora.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.