Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have this line in my fstab:

sshfs#ecarroll@o99:/opt/dealermade/ftp/inc /opt/dealermade/ftp/inc fuse defaults,idmap=user,users 0 0

For whatever reason it didn't work -- that's fine. How do I make it not stop the boot sequence. It prompted me to to hit S to skip or M to manually repair. If it isn't the boot volume, I just want my volumes to fail mounting with nothing more than an entry in logs.

share|improve this question
add comment

1 Answer

I'm not familiar with sshfs, but I know the nobootwait option works for local disk partitions. Maybe try:

sshfs#ecarroll@o99:/opt/dealermade/ftp/inc /opt/dealermade/ftp/inc fuse defaults,idmap=user,users,nobootwait 0 0

(A quick google search also shows archlinux uses nofail as per this thread. A little more googling shows that nobootwait might be a non-standard Ubuntu feature... curious to see if it resolves your issue. )

share|improve this answer
    
nofail did not resolve the issue, nobootwait did. –  Evan Carroll Oct 31 '12 at 17:52
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.