Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Current setup / versions :

  • Ubuntu Desktop 12.04
  • Linux 3.2.0-32
  • Xen 4.1-amd64
  • Grub2

After following the documentation to set up xen-hypervisor-amd64 and configuring grub2, when I reboot I get the below error:

(XEN) ********************
(XEN) Panic on CPU 0:
(XEN) Domain 0 allocation is too small for kernel image.
(XEN) ********************

My current /etc/default/grub

GRUB_DEFAULT="Xen 4.1-amd64"
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_XEN_DEFAULT="dom0_mem=1024M"

Which results in the following menuentry after update-grub

submenu "Xen 4.1-amd64" {
menuentry 'Ubuntu GNU/Linux, with Xen 4.1-amd64 and Linux 3.2.0-32-generic' --class ubuntu --class gnu-linux --class gnu --class os --class xen {
        insmod part_gpt
        insmod ext2
        set root='(hd0,gpt3)'
        search --no-floppy --fs-uuid --set=root dfeb1395-8583-4bed-bc97-8f2317a7e9dd
        echo    'Loading Xen 4.1-amd64 ...'
        multiboot       /boot/xen-4.1-amd64.gz placeholder  dom0_mem=1024M
        echo    'Loading Linux 3.2.0-32-generic ...'
        module  /boot/vmlinuz-3.2.0-32-generic placeholder root=UUID=dfeb1395-8583-4bed-bc97-8f2317a7e9dd ro  
        echo    'Loading initial ramdisk ...'
        module  /boot/initrd.img-3.2.0-32-generic
}

I have tried just about every possible dom0_mem= value that I can think of including but not limited to: dom0_mem=2097152, dom0_mem=min:1024M,max:1024M, moving the entry to the vmlinuz module, and including it in the follow-up linux menuentry.

I don't know what to try next. Any help is greatly appreciated.


With the addition of dom0_max_vcpus=2

multiboot /boot/xen-4.1-amd64.gz placeholder dom0_mem=1024M dom0_max_vcpus=2

I get the same boot panic. But interestingly in the info displayed at boot it continues to display "Brought up 4 CPUs".

Thanks again for any help!

share|improve this question
    
You could try the different options for the "acpi" Xen parameter. It could be that information from ACPI about memory regions is incorrect/incomplete... –  Stéphane Chazelas Oct 31 '12 at 14:15
    
I tried every acpi option with no change. –  bryfry Nov 1 '12 at 13:34

1 Answer 1

I don't think it's the dom0_mem that's an issue here. I think we're talking about space needed to load the kernel and initrd in memory into special area reserved by Xen.

Could it be that the initrd and/or vmlinuz are abnormally large. You could also try to reduce the number of CPUs available to dom0 (dom0_max_vcpus=2 for instance).

share|improve this answer
    
xen-4.1-amd64.gz is 715K, all my initrd and vmlinuz are less than 5M. See above about CPU's. –  bryfry Oct 31 '12 at 13:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.