Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
# grep '^inetd_flags="' /etc/rc.conf
inetd_flags="NO"                # for normal use: ""
# grep -i 'sendmail_flags="NO"' /etc/rc.conf
sendmail_flags="NO"
#

after a reboot..:
two questions:

# ps -aux | egrep -i "inetd|sendmail"
root      4420  0.0  0.1   452   652 ??  Is     8:10PM    0:00.00 /usr/sbin/inetd
#

QUESTION: How can I disable inetd, so that it will not start after a reboot? (+how can I disable sendmail correctly?)

share|improve this question
    
Why do you want to disable sendmail? –  gabe. Nov 4 '12 at 17:29
add comment

2 Answers

up vote 4 down vote accepted

You could delete the symlinks for them in the /etc/rc2.d (or rc3.d) directory. That will stop them from starting up at startup.

rm /etc/rc2.d/*sendmail* /etc/rc2.d/*inetd*

share|improve this answer
add comment

On OpenBSD 5.3 I didn't find any symlinks, it just has one /etc/rc/ directory, so I edited /etc/rc (lines starting with start_daemon).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.