Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I noticed, that the power consumption in my ASUS P53E notebook is doubled (from 10W to 20W) when I change from kernel 3.6.1 to 3.6.2 (or later). I use Ubuntu Quantal mainline kernel from kernel-ppa/mainline - Kernel Ubuntu on Mint 13 Maya (which is based on Ubuntu Precise 12.04).

Please advise me, what additional information I should post, to help you answer.

The power measurements agree with the significant difference in processor temperature (ca. 45 C on 10W and ca. 65 C on 20W), so it is not a glitch of the power meter.

share|improve this question
I noticed the same problem a few days ago, downgrading to an older kernel (3.0.xx, linux-lts on Arch) worked. – Renan Oct 29 '12 at 15:45
up vote 4 down vote accepted

I think there's a power utilization regression that was introduced in 3.6.x. If you can, stick with the older kernel. Supposedly, there's also an ext4 metadata block corruption bug in 3.6.2 as well, so it might be worth waiting.

share|improve this answer

If you have an easily reproducible bug between two kernel versions, the best thing to do is use git bisect to track down the exact cause and then report a bug to whoever made the offending change.

share|improve this answer
Thank you. This is exactly what I set to do. – Adam Ryczkowski Oct 29 '12 at 20:19

(Even though the question was already answered, am adding this just for the sake of completeness, since it's too big for a comment)

I had the same problem and downgrading to an older kernel solved it.

Investigating further, I found this thread in the Arch forum: Kernel 3.6.2 Power Regressions (Sandy Bridge).

Appears that it is a known bug, which has already been fixed and the fix will be available in newer versions of the kernel (I don't know if 3.6.4 fixed it).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.